Lastest Build WIP r775 Discuss (do not post builds) DAT+BAT*

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: Lastest Build WIP r450 Discuss (do not post builds)

Postby Ian » Thu Jun 16, 2016 2:05 pm

So you get a solid 60fps now ? :)
Ian
 
Posts: 1638
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r450 Discuss (do not post builds)

Postby Shekel » Thu Jun 16, 2016 4:24 pm

Ian wrote:So you get a solid 60fps now ? :)

Almost, it's a big difference. Also to ECA, which I'd forgotten had long bouts of slowdown. It's still got a few little moments, but I'm not complaining. It's much better now. Top work again, fella.
User avatar
Shekel
 
Posts: 345
Joined: Wed Mar 16, 2016 12:45 pm

Re: Lastest Build WIP r450 Discuss (do not post builds)

Postby artman999999 » Thu Jun 16, 2016 5:25 pm

Solid 60 FPS on SWT and LA Machineguns. But arguably the PC they are running on is no slouch - Core i7 w/16gigs and a GTX 970. I may have been getting those rates all along.
artman999999
 
Posts: 44
Joined: Wed Apr 27, 2016 9:36 am

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby terminento » Sat Jun 18, 2016 1:47 pm

I've been trying the latest revision, and it's awesome! There are no longer slowdowns in Star Wars cutscenes or during the trench run, and The Ocean Hunter, which used to be unbearably slow is now perfectly playbale!
Amazing job, guys!!!


(BTW, since I noticed it didn't have any impact on framerate, I force antialiasing via the Nvidia control panel, and the games look awesome!)
User avatar
terminento
 
Posts: 179
Joined: Fri Jun 15, 2012 8:08 am

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby karadaniano » Sun Jun 19, 2016 12:22 am

I tested harley with the last build.
Before this one i would get 56/57 fps before the ready go!
(And sometimes 30 fps)
Then it depended if i was going to the airport or beverly hills in the 1st stage.
In the former, 42 fps till the first turn to the left (the grass floor with 3 collectibles).
Then 60 fps near destination.

In the latter it would fluctuate.
57 fps till the first turn then constant 60 fps.
And sometimes, 45 fps till near beverly hills.

But now i get a solid 60 fps no matter whats the scenario.
User avatar
karadaniano
 
Posts: 179
Joined: Sat Sep 24, 2011 10:35 pm
Location: Buenos Aires, Argentina

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby sonic32 » Sun Jun 19, 2016 1:00 am

Hi speed in the latest SVN is very good.
Games are more stable, and better playable.
Scud Race, Daytona 2,Dirt Devil.. are at full speed and are very entertaining.
Thanks for the great job Ian, Bart.
:)
User avatar
sonic32
 
Posts: 123
Joined: Tue Dec 20, 2011 11:43 am
Location: Slovakia

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby Ian » Sun Jun 19, 2016 5:14 am

That's great news :)
Worst case, culling makes no difference, best case it throws out up to 60-70% of the geometry. Harley was creating up to 6k models, each model split by texture type, so potentially up to 10k draw calls per frame, which is extremely high.

Good news is, if culling works we might be able to use the same info to set proper near/far planes. I already prototyped something to extract the relavant z range and it seemed really promising.
Ian
 
Posts: 1638
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby DaytonaFan » Sun Jun 19, 2016 7:28 am

Tested Sega Rally 2 in legacy engine with this. Didn't use custom music, but I noticed that now I have 48-50FPS everywhere, with 50fps being nearly all the time and sometimes dropping to 45FPS but nothing more or less. I don't know if culling is implemented at all in Legacy engine. It seems that it's implemented in New engine though, as I tried the game, and with debug text appearing in the command line window, the framerate can get from 30FPS to 55FPS depending on the place (I noticed this most in the Attract mode, as the close-ups in the car got like 55FPS while the shot where your car is shown far gets 30FPS).

Daytona 2 PE in legacy engine got me 50fps in the attract mode, but strangely in gameplay it gets to 40FPS most of the time, dropping sometimes to 37fps. I can notice the framerate at least is getting more stable and better in the progress (Also noticed the lightning in the cars seems more accurate to what I can recall when I played in the arcades). New engine dropped as low as 24FPS most of the time, and with other things, wouldn't recommend playing Daytona 2 with New3D.

Virtual-On Oratorio Tangram in New3D still haves the attract bug but it runs great, with certain maps getting 50fps only, while most maps getting 58-54fps or something (Abandoned Quarry/Cave always was 60fps). Considering that it's the New3D, it works surprisingly great.
AKA TheArcadeStriker everywhere else :3
User avatar
DaytonaFan
 
Posts: 79
Joined: Thu Dec 01, 2011 11:21 am

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby Batman2509 » Sun Jun 19, 2016 8:07 am

All Games runs now much faster in "Window Mode", but when i try it in Fullscreen, the Games are slow....is there a Option gut get the Speed Improvement in Fullscreen, too?
My PC Spec, i7 4670k, 8gb ram, gtx780ti, Windows 10.
Batman2509
 
Posts: 28
Joined: Tue Mar 29, 2016 2:40 am

Re: Lastest Build WIP r451 Discuss (do not post builds)

Postby Ian » Sun Jun 19, 2016 8:11 am

what fps do you get in windowed mode?
Ian
 
Posts: 1638
Joined: Tue Feb 23, 2016 9:23 am

PreviousNext

Return to The Catwalk

Who is online

Users browsing this forum: Majestic-12 [Bot] and 7 guests